Feral reveals XCOM 2 Mac & Linux System Requirements

In a news post Feral Interactive have released the minimum and recommended system requirements for the upcoming XCOM 2. Head over to the link to see Linux requirements. Mac are below.

Minimum Mac:

  • OS: Mac OS X 10.11.2
  • Processor: 2.4 GHz Intel
  • Graphics card: 1GB NVIDIA 650ti or AMD 5770 or Intel Iris Pro or better

Recommended Mac:

  • OS: Mac OS X 10.11.2
  • Processor: 2.7 GHz i5
  • Graphics card: 2GB NVIDIA 700 series or AMD R9 series

Additionaly Feral adds: "Please note, AMD and Intel GPUs are not supported for Linux at time of release." 

Looks like its time for me to upgrade to El Capitan, as I haven't yet. I've been running 10.10.5 for awhile and have had no need to change. But I'll certainly change for this game.

XCOM 2 will release worldwide on Februry 5th for PC/Mac/Linux. Feral says it will be on the Mac App Store "soon." 

X